>
Node.js 设置镜像源问题
2022-12-21 11:01
前端
  • 2693
  • 527
  • 64
  • 51

前端安装完 node 后,最好设置下淘宝镜像源

npm install --registry=https://registry.npm.taobao.org

 执行会出现如下信息

    npm WARN EBADENGINE Unsupported engine {

    npm WARN EBADENGINE   package: '@achrinza/node-ipc@9.2.2',

    npm WARN EBADENGINE   required: { node: '8 || 10 || 12 || 14 || 16 || 17' },

    npm WARN EBADENGINE   current: { node: 'v18.12.0', npm: '8.19.2' }

    npm WARN EBADENGINE }


大体意思就是:只支持 node:“8||10||12||14||16||17” 18的node版本不支持

npm WARN EBADENGINE:{node:“8||10||12||14||16||17”},

npm WARN EBADENGINE当前:{node:“v18.12.0”,npm:“8.19.2”}

别看是个警告 很致命的哟。





全部留言 ()
返回
顶部